Create Method (XYZ, XYZ)


BRep Builder Edge Geometry Create(XYZ, XYZ) Method

Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BRepBuilderEdgeGeometry Create(
	XYZ startPoint,
	XYZ endPoint
)

Parameters

startPoint XYZ
endPoint XYZ

Return Value

BRepBuilderEdgeGeometry
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException The vectors startPoint and endPoint are coincident.
See Also