Adds a combined parameter field at the specified position in the list.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- data
- Type: System.Collections.GenericIListTableCellCombinedParameterData
The combined parameters array.
- fieldName
- Type: SystemString
The field name.
- index
- Type: SystemInt32
The index in the list of fields.
Return Value
The new field.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | index is not a valid insert position. |