InsertCombinedParameterField Method


Schedule Definition Insert Combined Parameter Field Method

Adds a combined parameter field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ScheduleField InsertCombinedParameterField(
	IList<TableCellCombinedParameterData> data,
	string fieldName,
	int index
)

Parameters

data IList TableCellCombinedParameterData
The combined parameters array.
fieldName String
The field name.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException index is not a valid insert position.
See Also