RemoveFabricReinforcementSystem Method


Deletes the specified FabricArea, and converts its FabricSheet elements to equivalent Single Fabric Sheet elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static IList<ElementId> RemoveFabricReinforcementSystem(
	Document doc,
	FabricArea system
)
Visual Basic
Public Shared Function RemoveFabricReinforcementSystem ( _
	doc As Document, _
	system As FabricArea _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ RemoveFabricReinforcementSystem(
	Document^ doc, 
	FabricArea^ system
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document.
system
Type: Autodesk.Revit.DB.StructureFabricArea
An FabricArea Reinforcement element in the document.

Return Value

The ids of the newly created Single Fabric Sheet elements.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element system was not found in the given document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also