Fabric |
Deletes the specified FabricArea, and converts its FabricSheet elements to equivalent Single Fabric Sheet elements.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<ElementId> RemoveFabricReinforcementSystem(
Document doc,
FabricArea system
)
Parameters
- doc Document
- The document.
- system FabricArea
- An FabricArea Reinforcement element in the document.
Return Value
IList ElementIdThe ids of the newly created Single Fabric Sheet elements.

Exception | Condition |
---|---|
ArgumentException | The element system was not found in the given document. |
ArgumentNullException | A non-optional argument was null |