CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)


Factory method - creates analysis display style object of type Markers and Text for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
	Document document,
	string name,
	AnalysisDisplayMarkersAndTextSettings markersAndTextSettings,
	AnalysisDisplayColorSettings colorSettings,
	AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Shared Function CreateAnalysisDisplayStyle ( _
	document As Document, _
	name As String, _
	markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings, _
	colorSettings As AnalysisDisplayColorSettings, _
	legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
	Document^ document, 
	String^ name, 
	AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings, 
	AnalysisDisplayColorSettings^ colorSettings, 
	AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DBDocument
Document for which analysis display style object is created.
name
Type: SystemString
Name of the analysis display style within the %document%.
markersAndTextSettings
Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayMarkersAndTextSettings
Markers and text settings for the style.
colorSettings
Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayColorSettings
Color settings for the style.
legendSettings
Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

New analysis display style object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentsInconsistentException document is a family. -or- name is not unique in document.

See Also