Analysis |
Factory method - creates analysis display style object of type Markers and Text for the given document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
Document document,
string name,
AnalysisDisplayMarkersAndTextSettings markersAndTextSettings,
AnalysisDisplayColorSettings colorSettings,
AnalysisDisplayLegendSettings legendSettings
)
Parameters
- document Document
- Document for which analysis display style object is created.
- name String
- Name of the analysis display style within the %document%.
- markersAndTextSettings AnalysisDisplayMarkersAndTextSettings
- Markers and text settings for the style.
- colorSettings AnalysisDisplayColorSettings
- Color settings for the style.
- legendSettings AnalysisDisplayLegendSettings
- Legend settings for the style.
Return Value
AnalysisDisplayStyleNew analysis display style object.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentsInconsistentException | document is a family. -or- name is not unique in document. |