Shape Property


The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic
Public Overridable ReadOnly Property Shape As ConnectorProfileType
	Get
Visual C++
public:
virtual property ConnectorProfileType Shape {
	ConnectorProfileType get ();
}

Implements

IConnectorShape

Remarks

ConnectorProfileType::Invalid if the connector is electrical or undefined.

See Also