AddSingleContour Method


Add a single contour as a contour setting item to the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ContourSettingItem AddSingleContour(
	double elevation,
	ElementId subcategoryId
)
Visual Basic
Public Function AddSingleContour ( _
	elevation As Double, _
	subcategoryId As ElementId _
) As ContourSettingItem
Visual C++
public:
ContourSettingItem^ AddSingleContour(
	double elevation, 
	ElementId^ subcategoryId
)

Parameters

elevation
Type: SystemDouble
The contour elevation.
subcategoryId
Type: Autodesk.Revit.DBElementId
The contour line style subcategory id.

Return Value

The newly added contour setting item.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given value for elevation is not finite
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also