AddSingleContour Method


Contour Setting Add Single Contour Method

Add a single contour as a contour setting item to the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ContourSettingItem AddSingleContour(
	double elevation,
	ElementId subcategoryId
)

Parameters

elevation Double
The contour elevation.
subcategoryId ElementId
The contour line style subcategory id.

Return Value

ContourSettingItem
The newly added contour setting item.
Exceptions
Exception Condition
ArgumentException The given value for elevation is not finite
ArgumentNullException A non-optional argument was null
See Also