GetWallSweepsInfo Method


Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<WallSweepInfo> GetWallSweepsInfo(
	WallSweepType wallSweepType
)
Visual Basic
Public Function GetWallSweepsInfo ( _
	wallSweepType As WallSweepType _
) As IList(Of WallSweepInfo)
Visual C++
public:
IList<WallSweepInfo^>^ GetWallSweepsInfo(
	WallSweepType wallSweepType
)

Parameters

wallSweepType
Type: Autodesk.Revit.DBWallSweepType
Whether to obtain wall sweeps or reveals.

Return Value

An array which describes the intrinsic wall sweeps or reveals.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also