RemoveAllTriggers Method


Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static void RemoveAllTriggers(
	UpdaterId id
)
Visual Basic
Public Shared Sub RemoveAllTriggers ( _
	id As UpdaterId _
)
Visual C++
public:
static void RemoveAllTriggers(
	UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DBUpdaterId
Id of specified updater

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveAllTriggers called while executing an updater.

See Also