RemoveAllTriggers Method


Updater Registry Remove All Triggers Method

Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RemoveAllTriggers(
	UpdaterId id
)

Parameters

id UpdaterId
Id of specified updater
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveAllTriggers called while executing an updater.
See Also