GetLabelFor Method (PipeLossMethodType, Document)


Gets the user-visible name for a PipeLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string GetLabelFor(
	PipeLossMethodType pipeLossMethodType,
	Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
	pipeLossMethodType As PipeLossMethodType, _
	doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
	PipeLossMethodType pipeLossMethodType, 
	Document^ doc
)

Parameters

pipeLossMethodType
Type: Autodesk.Revit.DB.PlumbingPipeLossMethodType
The PipeLossMethodType to get the user-visible name.
doc
Type: Autodesk.Revit.DBDocument
The document from which to get the PipeLossMethodType.

Remarks

The name is obtained in the current Revit language.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when information for the input PipeLossMethodType cannot be found.

See Also