Creates a space type.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- name
- Type: SystemString
The space type name.
Return Value
The new space type.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a space type name. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |