Create Method


HVACLoad Space Type Create Method

Creates a space type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static HVACLoadSpaceType Create(
	Document document,
	string name
)

Parameters

document Document
The document.
name String
The space type name.

Return Value

HVACLoadSpaceType
The new space type.
Exceptions
Exception Condition
ArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a space type name.
ArgumentNullException A non-optional argument was null
See Also