Sets visibility for a workset in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- worksetId
- Type: Autodesk.Revit.DBWorksetId
Id of the workset.
- visible
- Type: Autodesk.Revit.DBWorksetVisibility
The visibility of the workset.
Remarks
It works even when the workset is closed. This settings overrules implicit visibility of the workset (for this particular view only).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | There is no workset with this Id in the document associated with this view. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |