View Set |
Sets visibility for a workset in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- worksetId WorksetId
- Id of the workset.
- visible WorksetVisibility
- The visibility of the workset.

Exception | Condition |
---|---|
ArgumentException | There is no workset with this Id in the document associated with this view. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

It works even when the workset is closed. This settings overrules implicit visibility of the workset (for this particular view only).