TransactionAttribute Class


The custom transaction attribute to control the transaction behavior of the external command.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class TransactionAttribute : Attribute
Visual Basic
Public Class TransactionAttribute _
	Inherits Attribute
Visual C++
public ref class TransactionAttribute : public Attribute

Inheritance Hierarchy

SystemObject
  SystemAttribute
    Autodesk.Revit.AttributesTransactionAttribute

See Also