TransactionAttribute Class


Transaction Attribute Class

The custom transaction attribute to control the transaction behavior of the external command.
Inheritance Hierarchy
System Object
System Attribute
Autodesk.Revit.Attributes TransactionAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TransactionAttribute : Attribute

The TransactionAttribute type exposes the following members.

Constructors
Name Description
Public method TransactionAttribute Constructs a new TransactionAttribute.
Top
Properties
Name Description
Public property Mode Transaction mode.
Top
Methods
Name Description
Top
See Also