TransactionAttribute Class


Transaction Attribute Class

The custom transaction attribute to control the transaction behavior of the external command.
Inheritance Hierarchy
System Object
System Attribute
Autodesk.Revit.Attributes TransactionAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TransactionAttribute : Attribute

The TransactionAttribute type exposes the following members.

Constructors
Name Description
Public method TransactionAttribute Constructs a new TransactionAttribute.
Top
Properties
Name Description
Public property Mode Transaction mode.
Public property TypeId When implemented in a derived class, gets a unique identifier for this Attribute .
(Inherited from Attribute )
Top
Methods
Name Description
Public method Equals Returns a value that indicates whether this instance is equal to a specified object.
(Inherited from Attribute )
Public method GetHashCode Returns the hash code for this instance.
(Inherited from Attribute )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsDefaultAttribute When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
(Inherited from Attribute )
Public method Match When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
(Inherited from Attribute )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also