Draws a split line on the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- startVertex
- Type: Autodesk.Revit.DBSlabShapeVertex
The vertex to start the split line.
- endVertex
- Type: Autodesk.Revit.DBSlabShapeVertex
The vertex to end the split line.
Return Value
The newly created creases.Remarks
Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input vertex is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input vertex is invalid. |