DrawSplitLine Method


Slab Shape Editor Draw Split Line Method

Note: This API is now obsolete.

Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")]
public SlabShapeCreaseArray DrawSplitLine(
	SlabShapeVertex startVertex,
	SlabShapeVertex endVertex
)

Parameters

startVertex SlabShapeVertex
The vertex to start the split line.
endVertex SlabShapeVertex
The vertex to end the split line.

Return Value

SlabShapeCreaseArray
The newly created creases.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input vertex is .
ArgumentException Thrown when the input vertex is invalid.
Remarks
Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
See Also