Returns an instance of the specified Numbering Schema in the given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
A document to get the numbering schema from.
- schemaType
- Type: Autodesk.Revit.DBNumberingSchemaType
The type of a built-in schema to get.
Return Value
Instance of the specified schema.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given schemaType has an invalid Id. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |