Gets the line pattern id associated with this category for the given graphics style type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- graphicsStyleType
- Type: Autodesk.Revit.DBGraphicsStyleType
The type of graphics style.
Return Value
Returns the line pattern id associated with this category for the given graphics style type.Remarks
- The line pattern id will be one of the following:
- A negative value (representing a built-in line pattern)
- The id of a LinePatternElement
- InvalidElementId, indicating that this category does not have a stored line pattern id for this graphics style type.