Creates a new instance of toposolid within the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document in which the new toposolid is created.
- points
- Type: System.Collections.GenericIListXYZ
An array of points that used to construct the top face of the toposolid.
- topoTypeId
- Type: Autodesk.Revit.DBElementId
Id of the toposolid type to be used by the new toposolid.
- levelId
- Type: Autodesk.Revit.DBElementId
Id of the level on which the toposolid is to be placed.
Return Value
A new toposolid object within the project if successful.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input point array size is less than 3. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Cannot generate a sketch. -or- Failed to create new element. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |