Create Method (Document, IList(XYZ), ElementId, ElementId)


Toposolid Create(Document, IList XYZ , Element Id, Element Id) Method

Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Toposolid Create(
	Document document,
	IList<XYZ> points,
	ElementId topoTypeId,
	ElementId levelId
)

Parameters

document Document
The document in which the new toposolid is created.
points IList XYZ
An array of points that used to construct the top face of the toposolid.
topoTypeId ElementId
Id of the toposolid type to be used by the new toposolid.
levelId ElementId
Id of the level on which the toposolid is to be placed.

Return Value

Toposolid
A new toposolid object within the project if successful.
Exceptions
Exception Condition
ArgumentException The input point array size is less than 3. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException A non-optional argument was null
InvalidOperationException Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also