IsSystemClassificationValid Method


Checks that the MEPSystemType is valid for the domain of connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool IsSystemClassificationValid(
	MEPSystemClassification systemClassification
)
Visual Basic
Public Function IsSystemClassificationValid ( _
	systemClassification As MEPSystemClassification _
) As Boolean
Visual C++
public:
bool IsSystemClassificationValid(
	MEPSystemClassification systemClassification
)

Parameters

systemClassification
Type: Autodesk.Revit.DBMEPSystemClassification
The MEPSystemType to be validated.

Return Value

True if the MEPSystemType is valid for the domain of the connector, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also