IsSystemClassificationValid Method


Connector Element Is System Classification Valid Method

Checks that the MEPSystemType is valid for the domain of connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsSystemClassificationValid(
	MEPSystemClassification systemClassification
)

Parameters

systemClassification MEPSystemClassification
The MEPSystemType to be validated.

Return Value

Boolean
True if the MEPSystemType is valid for the domain of the connector, false otherwise.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also