Create Method


Creates a new instance of panel schedule on sheet and adds it to the document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static PanelScheduleSheetInstance Create(
	Document ADoc,
	ElementId scheduleId,
	View DBView
)
Visual Basic
Public Shared Function Create ( _
	ADoc As Document, _
	scheduleId As ElementId, _
	DBView As View _
) As PanelScheduleSheetInstance
Visual C++
public:
static PanelScheduleSheetInstance^ Create(
	Document^ ADoc, 
	ElementId^ scheduleId, 
	View^ DBView
)

Parameters

ADoc
Type: Autodesk.Revit.DBDocument
scheduleId
Type: Autodesk.Revit.DBElementId
DBView
Type: Autodesk.Revit.DBView

Return Value

The newly created panel schedule sheet instance element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also