Retrieves a parameter from the element given identifier.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameterTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the built-in parameter.
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter identifier to access the parameter. Autodesk Revit has a large number of built in parameters that are available via static properties.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter). |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was NULL |