GetParameter Method


Element Get Parameter Method

Retrieves a parameter from the element given identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Parameter GetParameter(
	ForgeTypeId parameterTypeId
)

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter.

Return Value

Parameter
Exceptions
Exception Condition
ArgumentException parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
ArgumentNullException A non-optional argument was NULL
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter identifier to access the parameter. Autodesk Revit has a large number of built in parameters that are available via static properties.
See Also