Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- lhs
- Type: SystemString
A value from an element in the document.
- rhs
- Type: SystemString
The user-supplied value against which values from the document are tested.
- caseSensitive
- Type: SystemBoolean
If true, string comparisons are done case-sensitively.
Return Value
True if the given arguments satisfy the condition, otherwise false.Remarks
The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |