Filter |
Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- lhs String
- A value from an element in the document.
- rhs String
- The user-supplied value against which values from the document are tested.
- caseSensitive Boolean
- If true, string comparisons are done case-sensitively.
Return Value
BooleanTrue if the given arguments satisfy the condition, otherwise false.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.