ArePartsValidForMerge Method


Identifies whether Part elements may be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static bool ArePartsValidForMerge(
	Document document,
	ICollection<ElementId> partIds
)
Visual Basic
Public Shared Function ArePartsValidForMerge ( _
	document As Document, _
	partIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ArePartsValidForMerge(
	Document^ document, 
	ICollection<ElementId^>^ partIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
partIds
Type: System.Collections.GenericICollectionElementId
Element ids of Parts.

Return Value

True if all element ids correspond to Part elements, none of the parts already has associated parts, the parts have contiguous geometry, all report the same materials, and all have the same creation and demolition phases.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also