ArePartsValidForMerge Method


Part Utils Are Parts Valid For Merge Method

Identifies whether Part elements may be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ArePartsValidForMerge(
	Document document,
	ICollection<ElementId> partIds
)

Parameters

document Document
The document.
partIds ICollection ElementId
Element ids of Parts.

Return Value

Boolean
True if all element ids correspond to Part elements, none of the parts already has associated parts, the parts have contiguous geometry, all report the same materials, and all have the same creation and demolition phases.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also