GetExportFontInfo Method


Gets a copy of the font info associated to the input font key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public ExportFontInfo GetExportFontInfo(
	ExportFontKey exportFontKey
)
Visual Basic
Public Function GetExportFontInfo ( _
	exportFontKey As ExportFontKey _
) As ExportFontInfo
Visual C++
public:
ExportFontInfo^ GetExportFontInfo(
	ExportFontKey^ exportFontKey
)

Parameters

exportFontKey
Type: Autodesk.Revit.DBExportFontKey
The export font Key.

Return Value

Returns the fontInfo for this key.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException An entry with the given key is not present in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also