Inserts a (key,info) pair into Export layer table.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exportLayerKey
- Type: Autodesk.Revit.DBExportLayerKey
The export layer key to be added.
- exportLayerInfo
- Type: Autodesk.Revit.DBExportLayerInfo
The export layer info to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The key already exists in the table. -or- The layer info does not contain the Category as a modifier type. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |