IsMasking Property


If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsMasking { get; set; }
Visual Basic
Public Property IsMasking As Boolean
	Get
	Set
Visual C++
public:
property bool IsMasking {
	bool get ();
	void set (bool value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: In a family a FilledRegionType with a solid fill pattern isMasking must always be true.

See Also