SetBuildingConstruction Method


Sets the Building Construction of the Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetBuildingConstruction(
	ConstructionType constructionType,
	Construction buildingConstruction
)
Visual Basic
Public Sub SetBuildingConstruction ( _
	constructionType As ConstructionType, _
	buildingConstruction As Construction _
)
Visual C++
public:
void SetBuildingConstruction(
	ConstructionType constructionType, 
	Construction^ buildingConstruction
)

Parameters

constructionType
Type: Autodesk.Revit.DB.AnalysisConstructionType
The Construction Type of Building Construction.
buildingConstruction
Type: Autodesk.Revit.DBConstruction
The Building Construction to be set.

Remarks

This function is used to set the Building Construction of the Project Information.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException buildingConstruction is NULL.
Autodesk.Revit.ExceptionsInvalidOperationException Sets construction type to an invalid value. - or - Can not set construction type.

See Also