MEPBuilding |
Sets the Building Construction of the Project Information.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetBuildingConstruction(
ConstructionType constructionType,
Construction buildingConstruction
)
Parameters
- constructionType ConstructionType
- The Construction Type of Building Construction.
- buildingConstruction Construction
- The Building Construction to be set.

Exception | Condition |
---|---|
ArgumentNullException | buildingConstruction is NULL. |
InvalidOperationException | Sets construction type to an invalid value. - or - Can not set construction type. |

This function is used to set the Building Construction of the Project Information.