IsValidGlobalParameter Method


Tests whether an ElementId is of a global parameter in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016 Subscription Update

Syntax

C#
public static bool IsValidGlobalParameter(
	Document document,
	ElementId parameterId
)
Visual Basic
Public Shared Function IsValidGlobalParameter ( _
	document As Document, _
	parameterId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidGlobalParameter(
	Document^ document, 
	ElementId^ parameterId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document containing the global parameter.
parameterId
Type: Autodesk.Revit.DBElementId
Id of a global parameter

Return Value

Returns True if the Id is of a valid global parameter; False otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also