GetSketchOnSurface Method


Gets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool GetSketchOnSurface(
	CurveElement curveElem
)
Visual Basic
Public Shared Function GetSketchOnSurface ( _
	curveElem As CurveElement _
) As Boolean
Visual C++
public:
static bool GetSketchOnSurface(
	CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DBCurveElement
The CurveElement.

Return Value

Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input CurveElement is not a CurveByPoints.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also