GetSketchOnSurface Method


Curve By Points Utils Get Sketch On Surface Method

Gets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool GetSketchOnSurface(
	CurveElement curveElem
)

Parameters

curveElem CurveElement
The CurveElement.

Return Value

Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.
Exceptions
Exception Condition
ArgumentException The input CurveElement is not a CurveByPoints.
ArgumentNullException A non-optional argument was null
See Also