An instance of another element (symbol), specially positioned by this
element.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
A GeometryInstance represents a set of geometry stored by Revit in a default configuration, and then transformed
into the proper location as a result of the properties of the element. The most common situation where
GeometryInstances are encountered is in Family instances. Revit uses GeometryInstances to allow it to store a
single copy of the geometry for a given family and reuse it in multiple instances.
Note that not all Family instances will include GeometryInstances. When Revit needs to make a unique copy of the
family geometry for a given instance (because of the effect of local joins, intersections, and other factors
related to the instance placement) no GeometryInstance will be encountered; instead the Solid geometry will be found
at the top level of the hierarchy.
Another example of GeometryInstance usage is in Rebar element visible in fine 3D Views. Here, each segement of a rebar is a GeometryInstance.
In this case the Symbol Element is contaning all the geometries that are instanced.
A GeometryInstance offers the ability to read its geometry through the GetSymbolGeometry() and
GetInstanceGeometry() methods. These methods return another Autodesk.Revit.DB.GeometryElement
which can be parsed just like the first level return.
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB GeometryInstance
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB GeometryInstance