GeometryInstance Class


Geometry Instance Class

An instance of another element (symbol), specially positioned by this element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GeometryInstance : GeometryObject

The GeometryInstance type exposes the following members.

Properties
Name Description
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property SymbolGeometry The geometric representation of the symbol which generates this instance.
Public property Code example Transform The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method GetDocument Gets the document that contains the symbol of this instance.
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetInstanceGeometry Computes the geometric representation of the instance.
Public method GetInstanceGeometry(Transform) Computes a transformation of the geometric representation of the instance.
Public method GetSymbolGeometry Computes the geometric representation of the symbol which generates this instance.
Public method GetSymbolGeometry(Transform) Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method GetSymbolGeometryId Gets the SymbolGeometryId that contains data about the symbol of this instance.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A GeometryInstance represents a set of geometry stored by Revit in a default configuration, and then transformed into the proper location as a result of the properties of the element. The most common situation where GeometryInstances are encountered is in Family instances. Revit uses GeometryInstances to allow it to store a single copy of the geometry for a given family and reuse it in multiple instances. Note that not all Family instances will include GeometryInstances. When Revit needs to make a unique copy of the family geometry for a given instance (because of the effect of local joins, intersections, and other factors related to the instance placement) no GeometryInstance will be encountered; instead the Solid geometry will be found at the top level of the hierarchy. Another example of GeometryInstance usage is in Rebar element visible in fine 3D Views. Here, each segement of a rebar is a GeometryInstance. In this case the Symbol Element is contaning all the geometries that are instanced. A GeometryInstance offers the ability to read its geometry through the GetSymbolGeometry() and GetInstanceGeometry() methods. These methods return another Autodesk.Revit.DB.GeometryElement which can be parsed just like the first level return.
See Also