GetAllExternalResourceReferences Method (Document, ExternalResourceType)


Gets the ids of all elements which refer to a specific type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static ISet<ElementId> GetAllExternalResourceReferences(
	Document document,
	ExternalResourceType resourceType
)
Visual Basic
Public Shared Function GetAllExternalResourceReferences ( _
	document As Document, _
	resourceType As ExternalResourceType _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetAllExternalResourceReferences(
	Document^ document, 
	ExternalResourceType^ resourceType
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The Revit Document containing the external resource references.
resourceType
Type: Autodesk.Revit.DBExternalResourceType
The type of external resource.

Return Value

The ids of all elements which refer to external resources of the specified type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also