GetAllExternalResourceReferences Method (Document, ExternalResourceType)


External Resource Utils Get All External Resource References(Document, External Resource Type) Method

Gets the ids of all elements which refer to a specific type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> GetAllExternalResourceReferences(
	Document document,
	ExternalResourceType resourceType
)

Parameters

document Document
The Revit Document containing the external resource references.
resourceType ExternalResourceType
The type of external resource.

Return Value

ISet ElementId
The ids of all elements which refer to external resources of the specified type.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also