ParameterDownloadOptions Constructor (ISet(ElementId), Boolean, Boolean, ForgeTypeId)


Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ParameterDownloadOptions(
	ISet<ElementId> categories,
	bool isInstance,
	bool visible,
	ForgeTypeId groupTypeId
)
Visual Basic
Public Sub New ( _
	categories As ISet(Of ElementId), _
	isInstance As Boolean, _
	visible As Boolean, _
	groupTypeId As ForgeTypeId _
)
Visual C++
public:
ParameterDownloadOptions(
	ISet<ElementId^>^ categories, 
	bool isInstance, 
	bool visible, 
	ForgeTypeId^ groupTypeId
)

Parameters

categories
Type: System.Collections.GenericISetElementId
The category identifiers.
isInstance
Type: SystemBoolean
True if binding to Element instances, false if binding to Element types.
visible
Type: SystemBoolean
True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
groupTypeId
Type: Autodesk.Revit.DBForgeTypeId
Properties palette group identifier.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also