This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- intersector
- Type: Autodesk.Revit.DBElementId
The intersector.
Return Value
True if the reference can be used to create a divided path, false otherwise.Remarks
Intersectors can be curve elements, datum planes, or divided paths. This function is should not be used to validate the input to SetIntersectors() because it does not check for self intersection of any other circular dependencies between intersectors. Use isIntersectorValidForDividedPath() instead.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |