Divided |
This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsIntersectorValidForCreation(
Document document,
ElementId intersector
)
Parameters
Return Value
BooleanTrue if the reference can be used to create a divided path, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Intersectors can be curve elements, datum planes, or divided paths. This function is should not be used to validate the input to SetIntersectors() because it does not check for self intersection of any other circular dependencies between intersectors. Use isIntersectorValidForDividedPath() instead.